Vous n'êtes pas identifié(e).

#1 2012-06-27 16:58:03

Chkris
Crunchbanger
Inscription : 2012-06-25
Messages : 8

Problème de dépendence libsqlite3-dev

Bonjour,

Il s'agit d'un problème de dépendance pour une installation de libsqlite3-dev :

Les paquets suivants contiennent des dépendances non satisfaites :
libsqlite3-dev : Dépend: libsqlite3-0 (= 3.7.3-1) mais 3.7.12.1-1~bpo60+1 devra être installé
E: Paquets défectueux



------
résultats de
for PACKAGE in $(aptitude search '~i((~Ddepends:libsqlite3-0)|(~Dpredepends:libsqlite3-0)|(~Drecommends:libsqlite3-0)|(~Dsuggests:libsqlite3-0))' -F '%p'); do echo "==> $PACKAGE"; aptitude show "?exact-name($PACKAGE)" | grep libsqlite3-0; done


==> aptitude
         5.7+20100313), libsigc++-2.0-0c2a (>= 2.0.2), libsqlite3-0 (>= 3.7.3),
==> iceweasel
==> libaprutil1-dbd-sqlite3
Dépend: libaprutil1 (= 1.3.9+dfsg-5), libc6 (>= 2.2.5), libsqlite3-0 (>= 3.7.2)
==> libnss3
         libsqlite3-0 (>= 3.7.3), zlib1g (>= 1:1.1.4)
==> libnss3-1d
==> libsoup-gnome2.4-1
         libsqlite3-0 (>= 3.7.3), libxml2 (>= 2.6.27), zlib1g (>= 1:1.1.4)
==> libsvn1
         libsasl2-2, libserf-0-0 (>= 0.3.0), libsqlite3-0 (>= 3.7.3), zlib1g (>=
==> libwebkit-1.0-2
         (>= 2.29.90), libsqlite3-0 (>= 3.7.3), libstdc++6 (>= 4.1.1), libxml2
==> python2.5
         libsqlite3-0 (>= 3.7.3), libssl0.9.8 (>= 0.9.8m-1)
==> python2.6
         libreadline6 (>= 6.0), libsqlite3-0 (>= 3.7.3)
==> xulrunner-10.0
         1.14.0), libpixman-1-0 (>= 0.18.0), libreadline6 (>= 6.0), libsqlite3-0
==> xulrunner-11.0
         libpixman-1-0 (>= 0.18.0), libreadline6 (>= 6.0), libsqlite3-0 (>=

------
résultats de apt-cache policy libsqlite3-0 libsqlite3-dev


libsqlite3-0:
  Installé : 3.7.12.1-1~bpo60+1
  Candidat : 3.7.12.1-1~bpo60+1
Table de version :
*** 3.7.12.1-1~bpo60+1 0
        100 http://backports.debian.org/debian-backports/ squeeze-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     3.7.10-1~bpo60+1 0
        100 http://packages.crunchbang.org/statler-mozilla/ squeeze-backports/iceweasel-release amd64 Packages
     3.7.3-1 0
        500 http://ftp.debian.org/debian/ squeeze/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ squeeze/main amd64 Packages
libsqlite3-dev:
  Installé : (aucun)
  Candidat : 3.7.3-1
Table de version :
     3.7.12.1-1~bpo60+1 0
        100 http://backports.debian.org/debian-backports/ squeeze-backports/main amd64 Packages
     3.7.10-1~bpo60+1 0
        100 http://packages.crunchbang.org/statler-mozilla/ squeeze-backports/iceweasel-release amd64 Packages
     3.7.3-1 0
        500 http://ftp.debian.org/debian/ squeeze/main amd64 Packages
        500 http://ftp.us.debian.org/debian/ squeeze/main amd64 Packages


Merci

Hors ligne

#2 2012-06-28 18:40:52

znk
Stratège en frite
Inscription : 2010-12-27
Messages : 1 126

Re : Problème de dépendence libsqlite3-dev

Peux tu essayer la commande "sudo apt-get -f install" et copier ce qui apparaît en sortie dans ton terminal ?
Cette commande propose de règler les problèmes de dépendances.

Hors ligne

Pied de page des forums